MFDeploy doesn't see my device. Help!

Jan 4, 2013 at 3:04 PM

I use STM324F-Discovery.

I loaded into the chip Tinybooter.hex

I use STM32 ST-LINK Utility v2.4.0.

Install usb driver STM32F4_WinUSB.

MFDeploy doesn't see my micro-usb device STM324F-Discovery. Help?

Feb 6, 2013 at 6:59 PM
Use CN5 USB. Not CN1 USB.

Check this post http://netmf4stm32.codeplex.com/discussions/400293
Mar 17, 2013 at 6:44 AM
I had this problem on Win7 x86 + VC# 2010 Express + NETMF 4.2. MFDeploy not seen "STM32 Net Test" device over USB.
The problem was resolved by upgrading to VC# 2012 Express and NETMF 4.3 (but in project to choose "4.2").
Mar 20, 2013 at 7:29 AM
I don't understand these designations. Use CN5 USB. Not CN1 USB.
I use mini-usb cable.

I will try option Oleole VC# 2012 Express and NETMF 4.3

results I will report
Mar 20, 2013 at 3:43 PM
Setup VC# 2012 and NETMF 4.3.

And works well.

thank you very much
Apr 29, 2015 at 8:52 PM
With VC# 2010 and NETMF 4.2, MFDeploy doesn't see my board. Setup VC# 2012 and NETMF 4.3, problem was solved. However, when I tried to deploy ER_FLASH and ER_CONFIG, I always got an error saying Checking signature failed with ER_FLASH.sig. Does anyone know what's going on?