This project is read-only.

A basic How-To-Get-Started??

Sep 3, 2012 at 1:46 PM


I've recently got a STM3220G-Eval kit and I'm keen to try get NETMF running on it, but I've got no experience with it and the reading that I've been doing hasn't really led me anywhere. I've downloaded the "" and programmed TinyBooter.hex into the board using the ST-Link utility. But now what? Can I get any output from the device (serial/usb)? Do I then program ER_FLASH.hex or ER_CONFIG.hex onto the board?

And then are there any other steps missing for me to get a simple NETMF app running on the board?


Any advice will be GREATLY appreciated...



Sep 4, 2012 at 9:35 AM

Further to this, I got the NETMF running on an STM32F4-Discovery. I still can't get MFDeploy to talk to the STM3220G-Eval. Any indication how I'm meant to do that? USB/Serial/Ethernet?



Sep 4, 2012 at 10:04 AM

A short "Getting started" would be great.

Sep 4, 2012 at 9:33 PM
Edited Sep 4, 2012 at 9:40 PM

Hi guys.


Ok. Tried and tested. (I also ran into the same scenario at first).

Connect kit via USB OTG to PC.

Make sure you have installed USB Drivers for Windows PCs on (It is listed on the lower part of the page)

Program TinyBooter.hex using ST-Link Utility.


Reset the STM3220G-EVAL using Reset button to enable enumeration.

For Windows box: Have a browse at your devices & printers section -> STM32 .Net Test should appear.

Ok, go to C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Tools\MFDeploy.exe and execute MFDeploy.


When pinging the device you should get the following reply:

Pinging...Tiny Booter

TinyBooterBootloader build info: Copyright Oberon microsystems, Inc.

Then load your ER_Flash and ER_Config and ... ST ARM rocks!

Hope it helps.


Sep 18, 2012 at 5:56 PM

I was able to get the ST-Link Utility to download the tinybooter, but after that MFDeploy saw nothing and there was nothing new under devices and printers (except st-link which was there). I plugged in the other USB (next to the headphone jack) and nothing there either. Did you do anything else? I sure would like to get this working.

Sep 18, 2012 at 6:09 PM
Edited Sep 18, 2012 at 6:42 PM

I tried it again, this time I erased the device first and now, with the USB next to the headphone jack plugged into the pc,  I see the STM32 .Net Test (under devices), but no joy pinging it from MFDeploy.

Sep 28, 2012 at 4:47 PM

Same issue on my end.  I'm seeing "STM32 .Net Test" in device manager, but when I bring up MFDeploy, I'm not finding the device.