MFDeploy: Signature check failed

Aug 6, 2012 at 12:33 PM

Hello, I am trying to get .NETMF running on an Discovery4 board. I wasn't able to compile the sources (it always failed), so I downloaded the three .hex files instead. I can upload TinyBooter.hex just fine with ST-Link (latest firmware), but MFDeploy always fails with "Error: Signature check failed for file ER_FLASH.sig". I have tried it both under Windows 7 x64 (used black magic to get the USB driver running) and Windows XP and it still gives me the same error. I have tried to sign the files using the commands in the Target menu, but that gives me errors about missing Crypto.dll, which is nowhere to be found. Any ideas? Lastly, I want to thank you guys for this amazing project, my board was collecting dust for nearly half a year before I found out about you.

Johnyz

Aug 14, 2012 at 2:15 PM

I am also experiencing the same issue. I read in another forum to just ignore the error and it will be fine. But that does not happen. Even when I ping the device from MFDeploy, it still says TinyBooter and not TinyCLR as it should. 

Visual Studio picks up the device, but when debugging on the device, VS hangs on the deployment part which I am assuming is because the ER_Config and ER_Flash files have not been loaded onto the device.

 

Zzykonn

Apr 29, 2015 at 9:01 PM
Have you figured out how to solve this problem?